Strona korzysta z plików cookies w celach statystycznych i zgodnie z Polityką Plików Cookies.
Możesz określić warunki przechowywania lub dostępu do plików cookies w Twojej przeglądarce lub całkowicie je wyłączyć.
Kliknij tu by przeczytać więcej o polityce plików cookies





                                                                      Witamy na stronie internetowej Publicznego Gimnazjum w Sieciechowie                                                                                                                                       e-mail gimnazjum: gimnazjumsieciechow@interia.pl      e-mail psp: pspsieciechow@interia.pl




                                                                                             Publiczne Gimnazjum
                                                                                              i Publiczna Szkoła Podstawowa
                                                                                            im. Armii Krajowej w Sieciechowie.

                                                                       www.zposieciechow.pl

Zespół Placówek Oświatowych w Sieciechowie (przedszkole, szkoła podstawowa i gimnazjum)

Zobacz: strona główna ZPO Sieciechów

Zobacz: pozostałe materiały dotyczące Logo Komeniusz

Logo komeniusz. Instrukcja powtarzania

W Logo komeniusz wystąpują sytuacje, w których pewne polecenia musimy powtarzać kilka razy. Na przykład rysując kwadrat o boku 100 musimy napisać:

np 100 pw 90
np 100 pw 90
np 100 pw 90
np 100 pw 90

Jak widać 4 razy piszemy polecenie: np 100 pw 90. W Logo Komeniusz istnieje instrukcja powtarzania, której schemat wygląda nastepująco:
powtórz x [lista poleceń do wykonania]
gdzie x oznacza liczbę potrzebnych powtórzeń,
[lista poleceń do wykonania] - to polecenia które chcemy powtórzyć zapisane w nawiasie kwadratowym [].

W przedstawionym przykładzie rysowanie kwadratu za pomocą instrukcji powtarzania będzie miało postać:
powtórz 4 [np 100 pw 90]

Polecenie powtórz 4 [np 100 pw 90] oznacza, że żółw powtórzy 4 razy polecenia, które są w nawiasie kwadratowym. Instrukcja powtarzania pozwala skrócić treść poleceń.

Logo komeniusz. Zadania do samodzielnego rozwiązania

Za pomocą instrukcji powtarzania języka Logo Komeniusz spróbuj narysować poniższe rysunki. Zastanów się w pierwszej kolejności jakie elementy poszczególnych rysunków powtarzają się i ile razy.

Po najechaniu myszką na rysunek pojawi się przykładowe prawidłowe rozwiązanie!!!

powtórz 12 [pod np 50 opu np 50 pod ws 100 opu pw 360/12] powtórz 4 [np 50 pod np 50 opu pw 90] powtórz 3 [np 50 pw 90 np 50 lw 90] powtórz 8 [np 100 ws 100 pw 360/8] powtórz 4 [np 100 ws 100 pw 90] powtórz 4 [np 40 pod np 40 opu] powtórz 4 [powtórz 4 [np 40 ws 40 pw 90] pod np 120 opu pw 90]

W jednej instrukcji powtarzania może się zawierać druga instrukcja powtarzania. Należy pamiętać o pozamykaniu każdego nawiasu. Na przykład: powtórz 2 [powtórz 4 [lista kroków] lista kroków]

Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów
page rank




Zostań Aniołem. Gimnazjum, Sieciechów, Zespół Placówek Oświatowych
Lepsza szkoła

Kliknij by zobaczyć galerię zdjęć i film z nadzania imienia i sztandaru Zespołowi Placówek Oświatowych w Sieciechowie. Zespół Placówek Oświatowych, gimnazjum i szkoła podstawowa, Sieciechów

Nadanie imienia. Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów


Gimnazjum im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów

Gimnazjum im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów

Szkoła Podstawowa im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów, gimnazjum

Certyfikat Zdamy.pl

Certyfikat Zdamy.pl dla Zespół Placówek Oświatowych, Sieciechów, gimnazjum

BIP - Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów

Poprawny CSS!

Ważny XHTML 1.0 Transitional

stat4u
Zespół Placówek Oświatowych im. Armii Krajowej w Sieciechowie w katalogu Gwiazdor

Informacje MEN
MEN
Informacje o reformie edukacji



Strony warte odwiedzenia
Mazowieckie Koratorium Oświaty
OKE Waw
Hermes
SIO
Gmina Sieciechów


Copyright ©: D. Kwieciński Zespół Placówek Oświatowych gimnazjum Sieciechów aktualizacja: 2012-11-24 13:36:04      Internetowe liczniki