Strona korzysta z plików cookies w celach statystycznych i zgodnie z Polityką Plików Cookies.
Możesz określić warunki przechowywania lub dostępu do plików cookies w Twojej przeglądarce lub całkowicie je wyłączyć.
Kliknij tu by przeczytać więcej o polityce plików cookies





                                                            Witamy na stronie internetowej Publicznego Gimnazjum w Sieciechowie                                                                            e-mail gimnazjum: gimnazjumsieciechow@interia.pl      e-mail psp: pspsieciechow@interia.pl






                                                                                  Publiczne Gimnazjum
                                                                                  i Publiczna Szkoła Podstawowa
                                                                                 im. Armii Krajowej w Sieciechowie.

                                                             www.zposieciechow.pl

Zespół Placówek Oświatowych w Sieciechowie (przedszkole, szkoła podstawowa i gimnazjum)

Zobacz: strona główna ZPO Sieciechów

Zobacz: pozostałe materiały dotyczące Logo Komeniusz

Logo komeniusz. Procedury

Logo komeniusz pozwala nam na zdefiniowanie własnych procedur, tak że po wywołaniu nazwy procedury powstaje gotowy rysunek, który w danej procedurze zdefiniowaliśmy. Procedury w Logo Komeniusz mogą być bezparametrowe lub mogą mieć parametry, czyli zmienne, które w danym momencie przyjmują okresloną wartość.

Zajmijmy się narysowaniem kwadratu o długości boku 100. Możemy go zapisać w postaci poleceń pierwotnych:
np 100 pw 90
np 100 pw 90
np 100 pw 90
np 100 pw 90

Możemy to samo zrobić za pomocą instrukcji powtarzania:
powtórz 4 [np 100 pw 90]

Możemy jednak nauczyć żółwia, że po wpisaniu słowa kwadrat, będzie on rysował na ekranie kwadrat. Należy zatem napisać procedurę kwadrat. Każda procedura ma pewien schemat wyglądu:
oto nazwaprocedury
treść procedury
już

Każda procedura rozpoczyna się słowem oto, a kończy słowem już. Obok słowa oto jest nazwaprocedury, która musi być zapisana jako jedno słowo!!! Procedura rysująca kwadrat będzie wyglądała następująco:
oto kwadrat
powtórz 4 [np 100 pw 90]
już

Jest to procedura bezparametrowa, co oznacza, że za każdym razem po użyciu słowa kwadrat powstanie rysunek kwadratu o długości boku 100. Żeby zmienić długość boku należy w takim przypadku w treści procedury w miejsce np 100 wpisać inną wartość lub zastosować procedurę z parametrem. Parametrem może być dowolna litera lub wyraz poprzedzony dwukropkiem, np. :a. Nasza procedura kwadrat z parametrem, który nazwę :bok będzie wyglądała następująco:
oto kwadrat :bok
powtórz 4 [np :bok pw 90]
już

Teraz wywołując procedurę kwadrat podajemy długość boku, np. kwadrat 50 (długość boku tego kwadratu wyniesie 50).


Logo komeniusz. Przykłady innych procedur

procedura prostokąt bezparametrowa

oto prostokąt
powtórz 2 [np 50 pw 90 np 100 pw 90]
już

procedura prostokąt z 2 parametrami

oto prostokąt :a :b
powtórz 2 [np :a pw 90 np :b pw 90]
już
gdzie :a i :b są długościami boków

procedura prostokąt z 1 parametrem

oto prostokąt :a
powtórz 2 [np :a pw 90 np :a/2 pw 90]
już
gdzie długość jednego boku wynosi :a, natomiast drugi bok jest 2 razy krótszy (stąd zapis :a/2)

procedura trójkąt równoboczny bez parametru

oto trójkąt
pw 30 powtórz 3 [np 100 pw 120]
już

procedura trójkąt równoboczny z parametrem :bok

oto trójkąt :bok
pw 30 powtórz 3 [np :bok pw 120]
już

procedura dowolny wielobok foremny

oto wielobok :bok :ile_bok
powtórz :ile_bok [np :bok pw 360 / :ile_bok]
już

gdzie :bok jest długością boku, :ile_bok liczbą (ilością) boków

procedura koło o dowolnym promieniu

Otóż obwód 36-boku równy jest 36 * długość boku. Natomiast obwód koła równy jest
2 * Pi * r. Przyrównajmy te dwie wartości do siebie:
2 * Pi * r = 36 * bok
Znając promień otrzymujemy: bok = (2 * Pi * r) / 36= 0,175 * r
procedura rysowania koła wygląda więc tak:

oto koło :promień
powtórz 36 [np :promień * 0,175 pw 10]
już

Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów
page rank
Logowanie do dziennika dla klasy 1a gimnazjum
Kliknij by zobaczyć galerię zdjęć i film z nadzania imienia i sztandaru Zespołowi Placówek Oświatowych w Sieciechowie. Zespół Placówek Oświatowych, gimnazjum i szkoła podstawowa, Sieciechów

Nadanie imienia. Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów


Gimnazjum im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów

Gimnazjum im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów

Szkoła Podstawowa im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów, gimnazjum

Certyfikat Zdamy.pl

Certyfikat Zdamy.pl dla Zespół Placówek Oświatowych, Sieciechów, gimnazjum

BIP - Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów

Poprawny CSS!

Ważny XHTML 1.0 Transitional

stat4u
Zespół Placówek Oświatowych im. Armii Krajowej w Sieciechowie w katalogu Gwiazdor

Informacje MEN
MEN
Nowe podręczniki do gimnazjum



Strony warte odwiedzenia
Mazowieckie Koratorium Oświaty
OKE Waw
Hermes
SIO
Gmina Sieciechów


Copyright ©: D. Kwieciński Zespół Placówek Oświatowych gimnazjum Sieciechów aktualizacja: 2012-11-24 15:10:36      Internetowe liczniki