Strona korzysta z plików cookies w celach statystycznych i zgodnie z Polityką Plików Cookies.
Możesz określić warunki przechowywania lub dostępu do plików cookies w Twojej przeglądarce lub całkowicie je wyłączyć.
Kliknij tu by przeczytać więcej o polityce plików cookies





                                                                      Witamy na stronie internetowej Publicznego Gimnazjum w Sieciechowie                                                                                                                                       e-mail gimnazjum: gimnazjumsieciechow@interia.pl      e-mail psp: pspsieciechow@interia.pl




                                                                                             Publiczne Gimnazjum
                                                                                              i Publiczna Szkoła Podstawowa
                                                                                            im. Armii Krajowej w Sieciechowie.

                                                                       www.zposieciechow.pl

Logo komeniusz. Rysowanie prostych figur

procedura kwadrat

do rozwiązywania zadań warto stosować dwie procedury kwadrat

a) kwadrat - rysowany w prawo z lewego dolnego narożnika (po prawej stronie żółwia)

oto kwadrat :bok
powtórz 4 [np. :bok pw 90]
już
Efekt procedury kwadrat 100. Logo Komeniusz. ZPO w Sieciechowie
b) kwadrat - rysowany od środka

oto kwadrat_s :bok
skok2 ( - :bok / 2 ) ( - :bok / 2 )
powtórz 4 [np :bok pw 90]
skok2 :bok / 2 :bok / 2
już
Efekt procedury kwadrat_s 100. Logo Komeniusz. ZPO w Sieciechowie

procedura prostokąt

a) prostokąt - rysowany w prawo z lewego dolnego narożnika (po prawej stronie żółwia)

oto prostokąt :a :b
powtórz 2 [np :a pw 90 np :b pw 90]
już

b) prostokąt - rysowany od środka


oto prostokąt_s :a :b
skok2 ( - :a / 2 ) ( - :b / 2 )
powtórz 2 [np :a pw 90 np :b pw 90]
skok2 :a / 2 :b / 2
już

procedura trójkąt równoboczny


a) trójkąt równoboczny - rysowany w prawo z lewego dolnego narożnika (po prawej stronie żółwia)

oto trójkąt :bok
powtórz 3 [np :bok pw 120]
już

Efekt wywołania procedury trójkąt. Logo Komeniusz. ZPO w Sieciechowie

b) trójkąt równoboczny - rysowany w prawo z lewego dolnego narożnika (po prawej stronie żółwia) - stojący na podstawie

oto trójkąt_1 :bok
pw 30
powtórz 3 [np :bok pw 120]
lw 30
już

Efekt wywołania procedury trójkąt_1. Logo Komeniusz. ZPO w Sieciechowie

c) trójkąt równoboczny - rysowany od środka - stojący na podstawie

oto trójkąt_s :bok
skok2 ( - :bok * ( pwk 3 ) / 6 ) ( - :bok / 2 )
pw 30
powtórz 3 [np :bok pw 120]
lw 30
skok2 ( :bok * ( pwk 3 ) / 6 ) ( :bok / 2 )
już
Efekt wywołania procedury trójkąt_s. Logo Komeniusz. ZPO w Sieciechowie

procedura dowolny wielobok foremny


a)wielobok - rysowany w prawo z lewego dolnego narożnika (po prawej stronie żółwia) oto wielobok :bok :ile_bok
powtórz :ile_bok [np :bok pw 360 / :ile_bok]
już

gdzie :bok jest długością boku, a :ile_bok liczbą (ilością) boków

procedura koło o dowolnym promieniu

Otóż obwód 36-boku równy jest 36 * długość boku. Natomiast obwód koła równy jest
2 * Pi * r. Przyrównajmy te dwie wartości do siebie:
2 * Pi * r = 36 * bok
Znając promień otrzymujemy: bok = (2 * Pi * r) / 36= 0,175 * r
procedura rysowania koła wygląda więc tak:

oto koło :promień
powtórz 36 [np :promień * 0,175 pw 10]
już

Efekt procedury koło. Logo Komeniusz. ZPO w Sieciechowie

procedura okrąg o dowolnym promieniu rysowany ze środka


oto okrąg :promień
skok2 0 ( - :promień )
powtórz 36 [np :promień * 0,175 pw 10]
skok2 0 ( :promień )
już

Efekt procedury okrąg. Logo Komeniusz. ZPO w Sieciechowie
Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów
page rank




Zostań Aniołem. Gimnazjum, Sieciechów, Zespół Placówek Oświatowych
Lepsza szkoła

Kliknij by zobaczyć galerię zdjęć i film z nadzania imienia i sztandaru Zespołowi Placówek Oświatowych w Sieciechowie. Zespół Placówek Oświatowych, gimnazjum i szkoła podstawowa, Sieciechów

Nadanie imienia. Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów


Gimnazjum im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów

Gimnazjum im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów

Szkoła Podstawowa im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów, gimnazjum

Certyfikat Zdamy.pl

Certyfikat Zdamy.pl dla Zespół Placówek Oświatowych, Sieciechów, gimnazjum

BIP - Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów

Poprawny CSS!

Ważny XHTML 1.0 Transitional

stat4u
Zespół Placówek Oświatowych im. Armii Krajowej w Sieciechowie w katalogu Gwiazdor

Informacje MEN
MEN
Informacje o reformie edukacji



Strony warte odwiedzenia
Mazowieckie Koratorium Oświaty
OKE Waw
Hermes
SIO
Gmina Sieciechów


Copyright ©: D. Kwieciński Zespół Placówek Oświatowych gimnazjum Sieciechów aktualizacja: 2012-01-18 10:22:57      Internetowe liczniki