Strona korzysta z plików cookies w celach statystycznych i zgodnie z Polityką Plików Cookies.
Możesz określić warunki przechowywania lub dostępu do plików cookies w Twojej przeglądarce lub całkowicie je wyłączyć.
Kliknij tu by przeczytać więcej o polityce plików cookies





                                                                      Witamy na stronie internetowej Publicznego Gimnazjum w Sieciechowie                                                                                                                                       e-mail gimnazjum: gimnazjumsieciechow@interia.pl      e-mail psp: pspsieciechow@interia.pl




                                                                                             Publiczne Gimnazjum
                                                                                              i Publiczna Szkoła Podstawowa
                                                                                            im. Armii Krajowej w Sieciechowie.

                                                                       www.zposieciechow.pl

Zmienne lokalne i globalne w Logo Komeniusz


Przykładowa procedura kwadrat może wyglądać tak:

oto kwadrat
powtórz 4 [np 100 pw 90]
już

Jej efektem będzie rysowanie kwadratu ale zawsze o boku 100. Można wprowadzić zmienną, która będzie bieżącą wartością długości boku. Nazwę ją :a. Procedura kwadrat z parametrem będzie teraz wyglądała tak:

oto kwadrat :a
powtórz 4 [np :a pw 90]
już

Czasem jednak w zadaniach wymagana jest procedura bezparametrowa, dlatego w takich przypadkach można posłużyć się zmienną lokalną niech lub globalną przyp.Procedura kwadrat będzie teraz wyglądała tak:

oto kwadrat
niech "a 200
powtórz 4 [np :a pw 90]
już

lub

oto kwadrat
przyp "a 200
powtórz 4 [np :a pw 90]
już

Można również wprowadzic w programie zmienną którą nazwiemy a i przypisać jej pewną wartość. Zmienną można utworzyć tak: f4-w oknie pamięć dodaj zmienną-nazwa: a, typ: tekst-wpisać wartość, np. 100. Procedura kwadrat będzie teraz wyglądała tak:

oto kwadrat
powtórz 4 [np :a pw 90]
już

Wszystkie opisane procedury dadzą ten sam efekt czyli narysowany zostanie kwadrat o podanym boku.

Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów
page rank




Zostań Aniołem. Gimnazjum, Sieciechów, Zespół Placówek Oświatowych
Lepsza szkoła

Kliknij by zobaczyć galerię zdjęć i film z nadzania imienia i sztandaru Zespołowi Placówek Oświatowych w Sieciechowie. Zespół Placówek Oświatowych, gimnazjum i szkoła podstawowa, Sieciechów

Nadanie imienia. Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów


Gimnazjum im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów

Gimnazjum im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów

Szkoła Podstawowa im. Armii Krajowej, Zespół Placówek Oświatowych, Sieciechów, gimnazjum

Certyfikat Zdamy.pl

Certyfikat Zdamy.pl dla Zespół Placówek Oświatowych, Sieciechów, gimnazjum

BIP - Zespół placówek Oświatowych - szkoła podstawowa i gimnazjum, Sieciechów

Poprawny CSS!

Ważny XHTML 1.0 Transitional

stat4u
Zespół Placówek Oświatowych im. Armii Krajowej w Sieciechowie w katalogu Gwiazdor

Informacje MEN
MEN
Informacje o reformie edukacji



Strony warte odwiedzenia
Mazowieckie Koratorium Oświaty
OKE Waw
Hermes
SIO
Gmina Sieciechów


Copyright ©: D. Kwieciński Zespół Placówek Oświatowych gimnazjum Sieciechów aktualizacja: 2012-01-18 11:03:22      Internetowe liczniki